<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Wise Slams Parkdale, Roosevelt Trounces Laurel | Afro</title>
<meta charset="UTF-8"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="fb:pages" content="36517112634"/>
<link rel="pingback" href="http://www.afro.com/xmlrpc.php"/>
<script type='text/javascript'>
var ct_ajaxurl = 'http://www.afro.com/wp-admin/admin-ajax.php';
 var ct_info_flag=true;
var ct_set_cookies_flag=true;
 </script>
<meta property="og:image" content="http://www.afro.com/wp-content/uploads/2016/09/Roosevelt.jpg"/><meta name="author" content="Special to the AFRO">
<link rel="icon" type="image/png" href="http://afro.com/wp-content/uploads/2016/05/afro-fav.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png"/><link rel="alternate" type="application/rss+xml" title="Afro &raquo; Feed" href="http://www.afro.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Afro &raquo; Comments Feed" href="http://www.afro.com/comments/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.afro.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=0734bd07978fff3de5f1935f4e07f0d3"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='camera-css-css' href='http://www.afro.com/wp-content/plugins/giga-slider/lib/camera/css/camera.css?ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='rcs-client-css-css' href='http://www.afro.com/wp-content/plugins/giga-slider/css/client.css?ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='mo_openid_admin_settings_style-css' href='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/css/mo_openid_style.css?version=4.8.3&#038;ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='mo_openid_admin_settings_phone_style-css' href='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/css/phone.css?ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='mo-wp-bootstrap-social-css' href='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/css/bootstrap-social.css?ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='mo-wp-bootstrap-main-css' href='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/css/bootstrap.min-preview.css?ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='mo-wp-font-awesome-css' href='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/css/font-awesome.min.css?version=4.8&#038;ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='ctf_styles-css' href='http://www.afro.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.css?ver=1.1.1' type='text/css' media='all'/>
<link rel='stylesheet' id='woocommerce-layout-css' href='//www.afro.com/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=2.6.1' type='text/css' media='all'/>
<link rel='stylesheet' id='woocommerce-smallscreen-css' href='//www.afro.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=2.6.1' type='text/css' media='only screen and (max-width: 768px)'/>
<link rel='stylesheet' id='woocommerce-general-css' href='//www.afro.com/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=2.6.1' type='text/css' media='all'/>
<link rel='stylesheet' id='google_font_open_sans-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='google_font_roboto-css' href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;ver=0734bd07978fff3de5f1935f4e07f0d3' type='text/css' media='all'/>
<link rel='stylesheet' id='cpsh-shortcodes-css' href='http://www.afro.com/wp-content/plugins/column-shortcodes/assets/css/shortcodes.css?ver=0.6.6' type='text/css' media='all'/>
<link rel='stylesheet' id='js_composer_front-css' href='http://www.afro.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.11.2' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='http://www.afro.com/wp-content/themes/Newspaper/style.css?ver=6.7.2' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-woo-css' href='http://www.afro.com/wp-content/themes/Newspaper/style-woocommerce.css?ver=6.7.2' type='text/css' media='all'/>
<link rel='stylesheet' id='wppa_style-css' href='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/theme/wppa-style.css?ver=6-4-20-004' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/jquery/jquery.form.min.js?ver=3.37.0'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/js/wppa-utils.min.js?ver=6-4-20-004'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/js/wppa.min.js?ver=6-4-20-004'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/js/wppa-slideshow.min.js?ver=6-4-20-004'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/js/wppa-ajax-front.min.js?ver=6-4-20-004'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/js/wppa-popup.min.js?ver=6-4-20-004'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/wp-photo-album-plus/wppa-init.en.js?ver=9'></script>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/giga-slider/lib/camera/scripts/jquery.mobile.customized.min.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/giga-slider/lib/camera/scripts/camera.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/giga-slider/js/client.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/js/jquery.cookie.min.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/miniorange-login-openid/includes/js/social_login.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='https://platform.twitter.com/widgets.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<link rel='https://api.w.org/' href='http://www.afro.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.afro.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.afro.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Mayor Stephanie Rawlings-Blake Attends Her Final Baltimore City Chamber of Commerce Breakfast' href='http://www.afro.com/mayor-stephanie-rawlings-blake-attends-her-final-baltimore-city-chamber-of-commerce-breakfast/'/>
<link rel='next' title='Fashion Umbrella Foundation’s First New York Fashion Week Showcase Puts Emerging Designers on the Map' href='http://www.afro.com/fashion-umbrella-foundations-first-new-york-fashion-week-showcase-puts-emerging-designers-on-the-map/'/>
<link rel="canonical" href="http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/"/>
<link rel='shortlink' href='http://www.afro.com/?p=144306'/>
<link rel="alternate" type="application/json+oembed" href="http://www.afro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.afro.com%2Fwise-slams-parkdale-roosevelt-trounces-laurel%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.afro.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.afro.com%2Fwise-slams-parkdale-roosevelt-trounces-laurel%2F&#038;format=xml"/>
<meta property="fb:pages" content="36517112634"/>
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.afro.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://www.afro.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
 
<script>
    

var tdBlocksArray = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.td_filter_value = ''; //current live filter value
    this.is_ajax_running = false;
    this.td_user_action = ''; // load more or infinite loader (used by the animation)
    this.header_color = '';
    this.ajax_pagination_infinite_stop = ''; //show load more at page x
}

    
    
        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_smooth_scroll=true;
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/www.afro.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.7.2";
var td_get_template_directory_uri="http:\/\/www.afro.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="show_header_logo";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="1";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#1e73be";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>
 
<style>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</style>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5147783-1', 'auto');
  ga('send', 'pageview');

</script>
 
<script type="text/javascript">
	wppaImageDirectory = "http://www.afro.com/wp-content/plugins/wp-photo-album-plus/images/";
	wppaWppaUrl = "http://www.afro.com/wp-content/plugins/wp-photo-album-plus";
	wppaIncludeUrl = "http://www.afro.com/wp-includes";
	wppaAjaxUrl = "http://www.afro.com/wp-content/plugins/wp-photo-album-plus/wppa-ajax-front.php";
	wppaUploadUrl = "http://www.afro.com/wp-content/uploads/wppa";
</script>
 
 
<style type="text/css"></style>
 
 
<noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1;}</style></noscript><script type="text/rocketscript">
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type="text/rocketscript">
  googletag.cmd.push(function() {
    googletag.defineSlot('/4708755/Maryland', [300, 250], 'div-gpt-ad-1457385570330-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
 
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/4708755/16_home_leaderboard_bottom', [728, 90], 'div-gpt-ad-1466385770500-0').addService(googletag.pubads());
    googletag.defineSlot('/4708755/16_home_leaderboard_top', [728, 90], 'div-gpt-ad-1466385770500-1').addService(googletag.pubads());
    googletag.defineSlot('/4708755/16_home_rectangle_left', [300, 250], 'div-gpt-ad-1466385770500-2').addService(googletag.pubads());
    googletag.defineSlot('/4708755/16_home_tower_right', [300, 600], 'div-gpt-ad-1466385770500-3').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
 
</head>
<body class="single single-post postid-144306 single-format-standard wise-slams-parkdale-roosevelt-trounces-laurel wpb-js-composer js-comp-ver-4.11.2 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div id="td-outer-wrap">
<div class="td-transition-content-and-menu td-mobile-nav-wrap">
<div id="td-mobile-nav">
 
<div class="td-mobile-close">
<a href="#">CLOSE</a>
<div class="td-nav-triangle"></div>
</div>
<div class="td-mobile-content">
<div class="menu-mainnav-container"><ul id="menu-mainnav" class=""><li id="menu-item-55864" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first menu-item-55864"><a href="#">Government</a>
<ul class="sub-menu">
<li id="menu-item-115096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115096"><a href="http://www.afro.com/section/dc_govt/">District of Columbia Government</a></li>
<li id="menu-item-115097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-115097"><a href="http://www.afro.com/section/dc_govt/dc_mayor/">Mayor Muriel Bowser Announcements</a></li>
<li id="menu-item-54648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54648"><a href="http://www.afro.com/section/maryland-government/">Maryland Government</a></li>
<li id="menu-item-88130" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88130"><a href="http://www.afro.com/section/maryland-government/senator_cardin/">Senator Cardin&#8217;s Announcements</a></li>
<li id="menu-item-88123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88123"><a href="http://www.afro.com/section/maryland-government/cummings_announcements/">Congressman Cumming&#8217;s Announcements</a></li>
<li id="menu-item-88125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88125"><a href="http://www.afro.com/section/maryland-government/edwards_announcements/">Congresswoman Edwards&#8217; Announcement</a></li>
<li id="menu-item-88124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88124"><a href="http://www.afro.com/section/maryland-government/sarbanes_announcements/">Congressman Sarbane&#8217;s Announcements</a></li>
<li id="menu-item-108998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108998"><a href="http://www.afro.com/section/maryland-government/hogan_announcements/">Governor Hogan&#8217;s Announcements</a></li>
<li id="menu-item-108999" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108999"><a href="http://www.afro.com/section/maryland-government/rutherford_announcements/">Lieutenant Rutherford&#8217;s Announcements</a></li>
<li id="menu-item-88122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88122"><a href="http://www.afro.com/section/maryland-government/franchot_announcements/">Comptroller Franchot&#8217;s Announcements</a></li>
<li id="menu-item-88128" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88128"><a href="http://www.afro.com/section/maryland-government/blake_announcement/">Mayor Rawlings-Blake&#8217;s Announcements</a></li>
<li id="menu-item-88129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88129"><a href="http://www.afro.com/section/maryland-government/young_announcements/">President Young&#8217;s Announcements</a></li>
</ul>
</li>
<li id="menu-item-6941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6941"><a href="http://www.afro.com/section/national-news/">National</a>
<ul class="sub-menu">
<li id="menu-item-141345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-141345"><a href="http://www.afro.com/2016-national-urban-league-conference/">2016 National Urban League Conference</a></li>
<li id="menu-item-141613" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-141613"><a href="http://www.afro.com/nabj-national-association-of-black-journalist-conference/">NABJ – National Association of Black Journalist Conference</a></li>
<li id="menu-item-141347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-141347"><a href="http://www.afro.com/section/dnc-2016/">DNC 2016</a></li>
<li id="menu-item-129148" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129148"><a href="http://www.afro.com/section/hallowed-grounds/">AFRO Black History 2016: Hallowed Grounds: Sites of African American Memories</a></li>
<li id="menu-item-122327" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-122327"><a href="http://www.afro.com/section/2015_million_man/">2015 Million Man March &#8211; &#8220;Justice or Else&#8221;</a></li>
<li id="menu-item-121209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-121209"><a href="http://www.afro.com/section/cbcf-45-2/">AFRO&#8217;s 45th Annual CBCF Annual Legislative Coverage</a></li>
</ul>
</li>
<li id="menu-item-55865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55865"><a href="#">Maryland</a>
<ul class="sub-menu">
<li id="menu-item-54641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54641"><a href="http://www.afro.com/section/baltimore-news/">Baltimore News</a></li>
<li id="menu-item-88069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88069"><a href="http://www.afro.com/baltimore-events/">Baltimore Events</a></li>
<li id="menu-item-55949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55949"><a href="http://www.afro.com/section/living-for-the-weekend/">Living for the Weekend</a></li>
<li id="menu-item-55950" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55950"><a href="http://www.afro.com/section/rambling-rose/">Rambling Rose</a></li>
<li id="menu-item-54649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54649"><a href="http://www.afro.com/section/obituaries-baltimore/">Obituaries &#8211; Baltimore</a></li>
<li id="menu-item-11855" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11855"><a href="http://www.afro.com/section/prince-georges-county-news/">Prince George&#8217;s County News</a></li>
</ul>
</li>
<li id="menu-item-6942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6942"><a href="http://www.afro.com/section/washington-d-c-news/">Washington</a>
<ul class="sub-menu">
<li id="menu-item-85899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85899"><a href="http://www.afro.com/section/washington-d-c-news/">Washington D.C. News</a></li>
<li id="menu-item-88064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88064"><a href="http://www.afro.com/dc-events/">DC Events</a></li>
<li id="menu-item-54650" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54650"><a href="http://www.afro.com/section/obituaries-washington-d-c/">Obituaries &#8211; Washington D.C.</a></li>
</ul>
</li>
<li id="menu-item-116983" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116983"><a href="http://www.afro.com/section/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-11856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11856"><a href="http://www.afro.com/section/sports/college/">College</a></li>
<li id="menu-item-56118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56118"><a href="http://www.afro.com/section/high-school/">High School</a></li>
<li id="menu-item-55951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55951"><a href="http://www.afro.com/section/sports/sports-columnists/">Sports Columnists</a></li>
</ul>
</li>
<li id="menu-item-6943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6943"><a href="http://www.afro.com/section/health/">Health</a>
<ul class="sub-menu">
<li id="menu-item-116755" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-116755"><a href="http://healthvideos.afro.com">BHTV Health Videos</a></li>
</ul>
</li>
<li id="menu-item-54638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54638"><a href="http://www.afro.com/section/arts-entertainment/">Arts &#038; Ent</a>
<ul class="sub-menu">
<li id="menu-item-56111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56111"><a href="http://www.afro.com/section/social-scene/">Social Scene</a></li>
<li id="menu-item-54642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54642"><a href="http://www.afro.com/section/books/">Books</a></li>
<li id="menu-item-56106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56106"><a href="http://www.afro.com/section/movie-reviews/">Movie Reviews</a></li>
</ul>
</li>
<li id="menu-item-54643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-54643"><a href="http://www.afro.com/section/business/">BUSINESS</a>
<ul class="sub-menu">
<li id="menu-item-93824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93824"><a href="http://www.afro.com/section/business/afro-advertise-with-us/">AFRO Advertise With Us</a></li>
<li id="menu-item-141124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-141124"><a href="http://www.afro.com/subscribe">Subscriptions</a></li>
</ul>
</li>
<li id="menu-item-56112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56112"><a href="http://www.afro.com/section/opinion/">OPINION</a>
<ul class="sub-menu">
<li id="menu-item-56113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56113"><a href="http://www.afro.com/section/opinion/editorial/">Editorial</a></li>
<li id="menu-item-56103" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56103"><a href="http://www.afro.com/section/opinion/commentary/">Commentary</a></li>
<li id="menu-item-56109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56109"><a href="http://www.afro.com/section/cartoons/">Cartoons</a></li>
</ul>
</li>
<li id="menu-item-87018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87018"><a href="http://www.afro.com/section/religion/">Religion</a>
<ul class="sub-menu">
<li id="menu-item-140340" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140340"><a href="http://www.afro.com/ame-2016/">AME 50th Quadrennial Session</a></li>
</ul>
</li>
<li id="menu-item-140887" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-140887"><a href="http://www.afro.com/archives/">Archives</a>
<ul class="sub-menu">
<li id="menu-item-141122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-141122"><a href="http://www.gettyimages.com/photos/afro?artist=gado&#038;excludenudity=false&#038;family=editorial&#038;page=1&#038;phrase=afro&#038;sort=mostpopular#license%20">AFRO GadoImages</a></li>
<li id="menu-item-141123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-141123"><a href="http://pqasb.pqarchiver.com/afro/advancedsearch.html%20">AFRO ProQuest</a></li>
</ul>
</li>
</ul></div> </div>
</div>
</div>
<div class="td-transition-content-and-menu td-content-wrap">
 
<div class="td-header-wrap td-header-style-1">
<div class="td-header-top-menu-full">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">Friday, September 16, 2016</div><div class="menu-top-container"><ul id="menu-topnav" class="top-header-menu"><li id="menu-item-11824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-11824"><a href="http://www.afro.com/section/baltimore-news/">Baltimore News</a></li>
<li id="menu-item-11825" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-11825"><a href="http://www.afro.com/section/washington-d-c-news/">Washington D.C. News</a></li>
<li id="menu-item-11826" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-11826"><a href="http://www.afro.com/section/prince-georges-county-news/">Prince George&#8217;s County News</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/AfroAmericanNews" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://instagram.com/afronews" title="Instagram"><i class="td-icon-font td-icon-instagram"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/afronew" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full">
<div class="td-container td-header-row td-header-header">
<div class="td-header-sp-logo">
<a href="http://www.afro.com/">
<img class="td-retina-data" data-retina="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png" src="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png" alt=""/>
</a>
</div>
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  td-rec-hide-on-p"><div id="div-gpt-ad-1466385770500-1" style="height: 90px; width: 728px;"><script type="text/javascript">// <![CDATA[
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466385770500-1'); });
// ]]></script></div></div>
</div> </div>
</div>
</div>
<div class="td-header-menu-wrap-full">
<div class="td-header-menu-wrap td-header-gradient">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo">
<a class="td-mobile-logo td-sticky-header" href="http://www.afro.com/">
<img class="td-retina-data" data-retina="http://afro.com/wp-content/uploads/2016/05/afr-logo-reversed.png" src="http://afro.com/wp-content/uploads/2016/05/afr-logo-reversed.png" alt=""/>
</a>
<a class="td-header-logo td-sticky-header" href="http://www.afro.com/">
<img class="td-retina-data" data-retina="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png" src="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png" alt=""/>
</a>
</div>
<div class="menu-mainnav-container"><ul id="menu-mainnav-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-55864"><a href="#">Government</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-115096"><a href="http://www.afro.com/section/dc_govt/">District of Columbia Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-115097"><a href="http://www.afro.com/section/dc_govt/dc_mayor/">Mayor Muriel Bowser Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54648"><a href="http://www.afro.com/section/maryland-government/">Maryland Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88130"><a href="http://www.afro.com/section/maryland-government/senator_cardin/">Senator Cardin&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88123"><a href="http://www.afro.com/section/maryland-government/cummings_announcements/">Congressman Cumming&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88125"><a href="http://www.afro.com/section/maryland-government/edwards_announcements/">Congresswoman Edwards&#8217; Announcement</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88124"><a href="http://www.afro.com/section/maryland-government/sarbanes_announcements/">Congressman Sarbane&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-108998"><a href="http://www.afro.com/section/maryland-government/hogan_announcements/">Governor Hogan&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-108999"><a href="http://www.afro.com/section/maryland-government/rutherford_announcements/">Lieutenant Rutherford&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88122"><a href="http://www.afro.com/section/maryland-government/franchot_announcements/">Comptroller Franchot&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88128"><a href="http://www.afro.com/section/maryland-government/blake_announcement/">Mayor Rawlings-Blake&#8217;s Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-88129"><a href="http://www.afro.com/section/maryland-government/young_announcements/">President Young&#8217;s Announcements</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6941"><a href="http://www.afro.com/section/national-news/">National</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-141345"><a href="http://www.afro.com/2016-national-urban-league-conference/">2016 National Urban League Conference</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-141613"><a href="http://www.afro.com/nabj-national-association-of-black-journalist-conference/">NABJ – National Association of Black Journalist Conference</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-141347"><a href="http://www.afro.com/section/dnc-2016/">DNC 2016</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-129148"><a href="http://www.afro.com/section/hallowed-grounds/">AFRO Black History 2016: Hallowed Grounds: Sites of African American Memories</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-122327"><a href="http://www.afro.com/section/2015_million_man/">2015 Million Man March &#8211; &#8220;Justice or Else&#8221;</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-121209"><a href="http://www.afro.com/section/cbcf-45-2/">AFRO&#8217;s 45th Annual CBCF Annual Legislative Coverage</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-55865"><a href="#">Maryland</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54641"><a href="http://www.afro.com/section/baltimore-news/">Baltimore News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-88069"><a href="http://www.afro.com/baltimore-events/">Baltimore Events</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55949"><a href="http://www.afro.com/section/living-for-the-weekend/">Living for the Weekend</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55950"><a href="http://www.afro.com/section/rambling-rose/">Rambling Rose</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54649"><a href="http://www.afro.com/section/obituaries-baltimore/">Obituaries &#8211; Baltimore</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-11855"><a href="http://www.afro.com/section/prince-georges-county-news/">Prince George&#8217;s County News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6942"><a href="http://www.afro.com/section/washington-d-c-news/">Washington</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-85899"><a href="http://www.afro.com/section/washington-d-c-news/">Washington D.C. News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-88064"><a href="http://www.afro.com/dc-events/">DC Events</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54650"><a href="http://www.afro.com/section/obituaries-washington-d-c/">Obituaries &#8211; Washington D.C.</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-116983"><a href="http://www.afro.com/section/sports/">Sports</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-11856"><a href="http://www.afro.com/section/sports/college/">College</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56118"><a href="http://www.afro.com/section/high-school/">High School</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-55951"><a href="http://www.afro.com/section/sports/sports-columnists/">Sports Columnists</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6943"><a href="http://www.afro.com/section/health/">Health</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-116755"><a href="http://healthvideos.afro.com">BHTV Health Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-54638"><a href="http://www.afro.com/section/arts-entertainment/">Arts &#038; Ent</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56111"><a href="http://www.afro.com/section/social-scene/">Social Scene</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-54642"><a href="http://www.afro.com/section/books/">Books</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56106"><a href="http://www.afro.com/section/movie-reviews/">Movie Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-54643"><a href="http://www.afro.com/section/business/">BUSINESS</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-93824"><a href="http://www.afro.com/section/business/afro-advertise-with-us/">AFRO Advertise With Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-141124"><a href="http://www.afro.com/subscribe">Subscriptions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-56112"><a href="http://www.afro.com/section/opinion/">OPINION</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56113"><a href="http://www.afro.com/section/opinion/editorial/">Editorial</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56103"><a href="http://www.afro.com/section/opinion/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-56109"><a href="http://www.afro.com/section/cartoons/">Cartoons</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-87018"><a href="http://www.afro.com/section/religion/">Religion</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-140340"><a href="http://www.afro.com/ame-2016/">AME 50th Quadrennial Session</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-140887"><a href="http://www.afro.com/archives/">Archives</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-141122"><a href="http://www.gettyimages.com/photos/afro?artist=gado&#038;excludenudity=false&#038;family=editorial&#038;page=1&#038;phrase=afro&#038;sort=mostpopular#license%20">AFRO GadoImages</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-141123"><a href="http://pqasb.pqarchiver.com/afro/advancedsearch.html%20">AFRO ProQuest</a></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">
 
<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form role="search" method="get" class="td-search-form" action="http://www.afro.com/">
<div class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search"/>
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
</div>
<div class="td-main-content-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://www.afro.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Prince George's County News" class="entry-crumb" itemprop="url" href="http://www.afro.com/section/prince-georges-county-news/"><span itemprop="title">Prince George's County News</span></a></span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-144306" class="post-144306 post type-post status-publish format-standard has-post-thumbnail hentry category-prince-georges-county-news" itemscope itemtype="http://schema.org/Article">
<div class="td-post-header">
<header class="td-post-title">
<h1 class="entry-title">Wise Slams Parkdale, Roosevelt Trounces Laurel</h1>
<h2 class="td-post-sub-title">Prince George’s County, Md. High School Football</h2>
<div class="td-module-meta-info">
<div class="author" style="display: inline-block; position: relative; top: 2px;">
by: Jordan Hawkins Special to the AFRO </div>
<div class="photographer" style="display: inline-block; position: relative; top: 2px;">
/ (Screengrab from video) / </div>
<div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-16T16:12:49+00:00">September 16, 2016</time></div>
<div class="td-post-comments"><a href="http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/#respond"><i class="td-icon-comments"></i>0</a></div>
<div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-144306">9</span></div>
</div>
</header>
</div>
<div class="td-post-sharing td-post-sharing-top td-with-like"><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/" data-text="Wise Slams Parkdale, Roosevelt Trounces Laurel" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>
<div class="td-post-content">
<p><span style="font-weight: 400;">Two teams claimed blowout wins over their rivals in Prince George’s County, Md. high school football action last week:</span> <span style="font-weight: 400;">The Parkdale Panthers (Riverdale, Md.) were routed by the visiting Wise Pumas (Upper Marlboro, Md.), 50-0, during a league outing on Sept. 10. Senior Quarterback Jabari Lewis led the Pumas to the shutout over the Panthers. The loss dropped Parkdale to 0-2 this season, while Wise improved to 2-0. The Pumas will host the Potomac Wolverines (Oxon Hill, Md.) in an out-of-county bout on Sept. 16. The Wolverines go into the game with a record of 0-1. Meanwhile, Parkdale will travel to face the DuVal Tigers (Lanham, Md.) in a Prince George’s County 4A outing on Sept. 17. The Tigers enter the game 1-1 after a win over Northwestern (Hyattsville, Md.).</span></p>
<p><span style="font-weight: 400;">Karl Mofor led the Eleanor Roosevelt Raiders (Greenbelt, Md.) in a 47-7 trouncing of the host Laurel Spartans (Laurel, Md.) on Sept. 10. The Raiders now boast a 1-1 record and will host the Northwestern Wildcats for another PG County 4A contest on Sept. 17. The Wildcats (1-1) enter the game off a 12-6 loss to DuVal. The same day, Laurel will face the High Point Eagles (Beltsville, Md.) in an in-county 4A contest.</span></p>
<p><iframe src="//www.hudl.com/embed/video/3/3323093/57cb14b83bd8141e3c9dffc3" width="640" height="400" frameborder="0" allowfullscreen="allowfullscreen"></iframe><em><br/>
(Player of the Week Karl Mofor, with the Eleanor Roosevelt Raiders, runs in a 60-yard touchdown.)</em></p>
<p><b>Offensive Player of the Week:</b><span style="font-weight: 400;"> Karl Mofor. Mofor boasted a strong showing against Laurel, rushing for 120 yards and four touchdowns on just nine carries, an average of 13 yards per carry.</span></p>
<p><b>Defensive Player of the Week:</b><span style="font-weight: 400;"> Willie Mabry. The senior defensive end from Wise High School is currently averaging 11 tackles per game and leading the region in sacks, and is a powerful constant in the Wise defensive lineup.</span></p>
<p><b>Games of the Week: </b><span style="font-weight: 400;">Bladensburg Mustangs (Bladensburg, Md.) at Flowers Jaguars (Springdale, Md.). The Jaguars appear to be the top 4A team in Prince George’s County. Flowers boasts a 2-0 record, but Bladensburg is definitely eager to change that and get their first win of the season with an upset.</span></p>
<p><span style="font-weight: 400;">Northwestern Wildcats (Hyattsville, Md.) at Eleanor Roosevelt Raiders (Greenbelt, Md.). Both teams own a 1-1 record, and each has one of the top two running backs in the region currently: Karl Mofor at Roosevelt and Shaka Victor at Northwestern. It will be interesting to see how the two offensive powerhouses clash. Northwestern hopes to stay strong and beat Roosevelt on the latter’s home turf.  However, the Raiders have not played at home yet and will be hard to beat with their home-field advantage.</span></p>
<p><span style="font-weight: 400;">Potomac Wolverines (Oxon Hill, Md.) vs. Wise Pumas (Upper Marlboro, Md.). Potomac will be Wise’s second out-of-region opponent as they hope to continue their winning streak. The matchup is Potomac’s first out-of-region game, but they face a tough test as they search for their first win of the season. </span></p>
<div class="td-a-rec td-a-rec-id-content_bottom  td-rec-hide-on-p"><p><a href="/subscribe/"><img src="/wp-content/uploads/2016/06/Subscribe-house-ad-leaderboard.png"></a></p></div>
</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span>
<div class="td-default-sharing">
<a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.afro.com%2Fwise-slams-parkdale-roosevelt-trounces-laurel%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
<a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Wise+Slams+Parkdale%2C+Roosevelt+Trounces+Laurel&url=http%3A%2F%2Fwww.afro.com%2Fwise-slams-parkdale-roosevelt-trounces-laurel%2F&via=afronews"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
<a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
<a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/&amp;media=http://www.afro.com/wp-content/uploads/2016/09/Roosevelt.jpg&description=Wise+Slams+Parkdale%2C+Roosevelt+Trounces+Laurel" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
<a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Wise+Slams+Parkdale%2C+Roosevelt+Trounces+Laurel - http%3A%2F%2Fwww.afro.com%2Fwise-slams-parkdale-roosevelt-trounces-laurel%2F"><i class="td-icon-whatsapp"></i></a>
</div></div>
<div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.afro.com/mayor-stephanie-rawlings-blake-attends-her-final-baltimore-city-chamber-of-commerce-breakfast/">Mayor Stephanie Rawlings-Blake Attends Her Final Baltimore City Chamber of Commerce Breakfast</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://www.afro.com/fashion-umbrella-foundations-first-new-york-fashion-week-showcase-puts-emerging-designers-on-the-map/">Fashion Umbrella Foundation’s First New York Fashion Week Showcase Puts Emerging Designers on the Map</a></div></div></div>
<div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://www.afro.com/author/special-to-the-afro/">Special to the AFRO</a></span></div>
<span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Special to the AFRO"></span><meta itemprop="datePublished" content="2016-09-16T16:12:49+00:00"><meta itemprop="dateModified" content="2016-09-16T16:17:30+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.afro.com/wise-slams-parkdale-roosevelt-trounces-laurel/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://afro.com/wp-content/uploads/2016/05/Afro-logo1.png"></span><meta itemprop="name" content="Afro"></span><meta itemprop="headline " content="Wise Slams Parkdale, Roosevelt Trounces Laurel"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.afro.com/wp-content/uploads/2016/09/Roosevelt.jpg"><meta itemprop="width" content="640"><meta itemprop="height" content="338"></span>
</footer>
</article>  
<script>var block_td_uid_1_57dc63ed5cd22 = new tdBlock();
block_td_uid_1_57dc63ed5cd22.id = "td_uid_1_57dc63ed5cd22";
block_td_uid_1_57dc63ed5cd22.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_1_57dc63ed5cd22_rand","td_column_number":3,"live_filter_cur_post_id":144306,"live_filter_cur_post_author":"11918"}';
block_td_uid_1_57dc63ed5cd22.td_column_number = "3";
block_td_uid_1_57dc63ed5cd22.block_type = "td_block_related_posts";
block_td_uid_1_57dc63ed5cd22.post_count = "3";
block_td_uid_1_57dc63ed5cd22.found_posts = "25862";
block_td_uid_1_57dc63ed5cd22.header_color = "";
block_td_uid_1_57dc63ed5cd22.ajax_pagination_infinite_stop = "";
block_td_uid_1_57dc63ed5cd22.max_num_pages = "8621";
tdBlocksArray.push(block_td_uid_1_57dc63ed5cd22);
</script><div class="td_block_wrap td_block_related_posts td_uid_1_57dc63ed5cd22_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_2_57dc63ed61d7a" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_57dc63ed5cd22" href="#">RELATED ARTICLES</a><a id="td_uid_3_57dc63ed61db7" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_57dc63ed5cd22" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_57dc63ed5cd22 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.afro.com/bobbi-kristina-browns-partner-defaults-in-civil-wrongful-death-case-against-him-faces-trial-on-damages/" rel="bookmark" title="Bobbi Kristina Brown&#8217;s Partner Defaults in Civil Wrongful Death Case Against Him—Faces Trial on Damages"><img width="218" height="150" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/People-Bobbi-Kristina_News-001-218x150.jpg" alt="" title="Bobbi Kristina Brown&#8217;s Partner Defaults in Civil Wrongful Death Case Against Him—Faces Trial on Damages"/></a></div> <a href="http://www.afro.com/section/arts-entertainment/" class="td-post-category">ARTS &amp; ENTERTAINMENT</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/bobbi-kristina-browns-partner-defaults-in-civil-wrongful-death-case-against-him-faces-trial-on-damages/" rel="bookmark" title="Bobbi Kristina Brown&#8217;s Partner Defaults in Civil Wrongful Death Case Against Him—Faces Trial on Damages">Bobbi Kristina Brown&#8217;s Partner Defaults in Civil Wrongful Death Case Against Him—Faces Trial on Damages</a></h3> </div>
</div>
</div>  
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.afro.com/trump-now-admits-obama-was-born-in-the-us/" rel="bookmark" title="Trump Now Admits Obama was Born in the US"><img width="218" height="150" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/DonaldTrump-PresObama-218x150.jpg" alt="" title="Trump Now Admits Obama was Born in the US"/></a></div> <a href="http://www.afro.com/section/national-news/" class="td-post-category">National News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/trump-now-admits-obama-was-born-in-the-us/" rel="bookmark" title="Trump Now Admits Obama was Born in the US">Trump Now Admits Obama was Born in the US</a></h3> </div>
</div>
</div>  
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="http://www.afro.com/comedian-katt-williams-arrested-again-jailed/" rel="bookmark" title="Comedian Katt Williams Arrested Again, Jailed"><img width="218" height="150" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/e6fff799a06b4d5e9cfdcb85cc774b99-218x150.jpg" alt="" title="Comedian Katt Williams Arrested Again, Jailed"/></a></div> <a href="http://www.afro.com/section/arts-entertainment/" class="td-post-category">ARTS &amp; ENTERTAINMENT</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/comedian-katt-williams-arrested-again-jailed/" rel="bookmark" title="Comedian Katt Williams Arrested Again, Jailed">Comedian Katt Williams Arrested Again, Jailed</a></h3> </div>
</div>
</div>  </div> </div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_57dc63ed5cd22" data-td_block_id="td_uid_1_57dc63ed5cd22"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_57dc63ed5cd22" data-td_block_id="td_uid_1_57dc63ed5cd22"><i class="td-icon-font td-icon-menu-right"></i></a></div></div>  
<div class="comments" id="comments">
<div class="td-comments-title-wrap ">
<h4 class="block-title"><span>NO COMMENTS</span></h4>
</div>
</div>  
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td-a-rec td-a-rec-id-sidebar "> 
<div id="div-gpt-ad-1466385770500-2" style="height: 250px; width: 300px;"><script type="text/javascript">// <![CDATA[
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466385770500-2'); });
// ]]></script></div>
<div id='div-gpt-ad-1466385770500-3' style='height:600px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466385770500-3'); });
</script>
</div>
</div><script>var block_td_uid_4_57dc63ed650a7 = new tdBlock();
block_td_uid_4_57dc63ed650a7.id = "td_uid_4_57dc63ed650a7";
block_td_uid_4_57dc63ed650a7.atts = '{"custom_title":"AFRO BRIEFS","custom_url":"","header_text_color":"#","header_color":"#","post_ids":"","category_id":"22","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","limit":"6","offset":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_4_57dc63ed650a7_rand"}';
block_td_uid_4_57dc63ed650a7.td_column_number = "1";
block_td_uid_4_57dc63ed650a7.block_type = "td_block_7";
block_td_uid_4_57dc63ed650a7.post_count = "6";
block_td_uid_4_57dc63ed650a7.found_posts = "4443";
block_td_uid_4_57dc63ed650a7.header_color = "#";
block_td_uid_4_57dc63ed650a7.ajax_pagination_infinite_stop = "";
block_td_uid_4_57dc63ed650a7.max_num_pages = "741";
tdBlocksArray.push(block_td_uid_4_57dc63ed650a7);
</script><div class="td_block_wrap td_block_7 td_block_widget td_uid_4_57dc63ed650a7_rand td_with_ajax_pagination td-pb-border-top"><h4 class="block-title"><span>AFRO BRIEFS</span></h4><div id=td_uid_4_57dc63ed650a7 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/lawyer-1-9-million-settlement-in-sandra-bland-lawsuit/" rel="bookmark" title="Lawyer: $1.9 Million Settlement in Sandra Bland Lawsuit"><img width="96" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2015/07/sandra-bland.png" alt="" title="Lawyer: $1.9 Million Settlement in Sandra Bland Lawsuit"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/lawyer-1-9-million-settlement-in-sandra-bland-lawsuit/" rel="bookmark" title="Lawyer: $1.9 Million Settlement in Sandra Bland Lawsuit">Lawyer: $1.9 Million Settlement in Sandra Bland Lawsuit</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-15T21:33:29+00:00">September 15, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/chief-boys-bb-gun-practically-identical-to-police-weapon/" rel="bookmark" title="Chief: Boy&#8217;s BB Gun &#8216;Practically Identical&#8217; to Police Weapon"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/Tyre-King-100x70.jpg" alt="" title="Chief: Boy&#8217;s BB Gun &#8216;Practically Identical&#8217; to Police Weapon"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/chief-boys-bb-gun-practically-identical-to-police-weapon/" rel="bookmark" title="Chief: Boy&#8217;s BB Gun &#8216;Practically Identical&#8217; to Police Weapon">Chief: Boy&#8217;s BB Gun &#8216;Practically Identical&#8217; to Police Weapon</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-15T17:49:50+00:00">September 15, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/man-ordered-held-without-bond-after-police-officers-struck-with-auto/" rel="bookmark" title="Man Ordered Held without Bond after Police Officers Struck with Auto"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/Officers-Struck_News-100x70.jpg" alt="" title="Man Ordered Held without Bond after Police Officers Struck with Auto"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/man-ordered-held-without-bond-after-police-officers-struck-with-auto/" rel="bookmark" title="Man Ordered Held without Bond after Police Officers Struck with Auto">Man Ordered Held without Bond after Police Officers Struck with Auto</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-14T16:32:27+00:00">September 14, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/biggest-street-gang-trial-in-recent-chicago-history-begins/" rel="bookmark" title="Biggest Street-Gang Trial in Recent Chicago History Begins"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/AP-Articles15-100x70.jpg" alt="" title="Biggest Street-Gang Trial in Recent Chicago History Begins"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/biggest-street-gang-trial-in-recent-chicago-history-begins/" rel="bookmark" title="Biggest Street-Gang Trial in Recent Chicago History Begins">Biggest Street-Gang Trial in Recent Chicago History Begins</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-14T16:08:47+00:00">September 14, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/judge-orders-jail-for-teen-who-allegedly-impersonated-doctor/" rel="bookmark" title="Judge Orders Jail for Teen Who Allegedly Impersonated Doctor"><img width="100" height="61" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/04/MalachiLoveRobinson.jpg" alt="" title="Judge Orders Jail for Teen Who Allegedly Impersonated Doctor"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/judge-orders-jail-for-teen-who-allegedly-impersonated-doctor/" rel="bookmark" title="Judge Orders Jail for Teen Who Allegedly Impersonated Doctor">Judge Orders Jail for Teen Who Allegedly Impersonated Doctor</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-14T12:40:43+00:00">September 14, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/black-world-war-ii-veteran-turns-107-with-a-party-in-new-orleans/" rel="bookmark" title="Black World War II Veteran Turns 107 with a Party in New Orleans"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/09/795dae1f5de43d2ea40f6a706700fd28-100x70.jpg" alt="" title="Black World War II Veteran Turns 107 with a Party in New Orleans"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/black-world-war-ii-veteran-turns-107-with-a-party-in-new-orleans/" rel="bookmark" title="Black World War II Veteran Turns 107 with a Party in New Orleans">Black World War II Veteran Turns 107 with a Party in...</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-09-13T09:17:25+00:00">September 13, 2016</time></div> </div>
</div>
</div>
</div>  </div></div>  <aside class="widget widget_text"> <div class="textwidget"><div class="vc_btn3-container  wpb_animate_when_almost_visible wpb_appear vc_btn3-center vc_custom_1466200670064 wpb_start_animation"><a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-modern vc_btn3-icon-left vc_btn3-color-primary" href="http://visitor.r20.constantcontact.com/d.jsp?llr=5chjcnbab&amp;p=oi&amp;m=1101023976542&amp;sit=txnztvuab&amp;f=f5575807-4d7b-4354-a823-80d58fd5adb6" title="" target="_blank"><i class="vc_btn3-icon fa fa-newspaper-o"></i> Signup for AFRO eBlast</a></div></div>
</aside>
</div>
</div>
</div>  
</div>  
</div>  
 
<div class="td-footer-wrapper td-footer-template-2">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-span3"></div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td-footer-info"><div class="footer-logo-wrap"><a href="http://www.afro.com/"><img class="td-retina-data" src="http://afro.com/wp-content/uploads/2016/05/afr-logo-reversed.png" data-retina="http://afro.com/wp-content/uploads/2016/05/afr-logo-reversed.png" alt="" title=""/></a></div><div class="footer-text-wrap">Phone: 800-AFRO-892 (800-237-6892)<BR>
Fax: 877-570-9297<p>
Baltimore, MD Office<BR>
2519 North Charles Street<BR>
Baltimore, MD 21218<BR>
Voice: 410-554-8200<p>
Washington, DC Office<BR>
1816 12th Street NW<BR>
Washington, DC 20009<BR>
Phone: 202-332-0080
 <div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#790e1c1b1c1d100d160b39181f0b16571a1614"><span class="__cf_email__" data-cfemail="95e2f0f7f0f1fce1fae7d5f4f3e7fabbf6faf8">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></a></div></div><div class="footer-social-wrap td-social-style-2"><span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/AfroAmericanNews" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://instagram.com/afronews" title="Instagram"><i class="td-icon-font td-icon-instagram"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/afronew" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></div></div> </div>
<div class="td-pb-span1"></div>
<div class="td-pb-span4">
<script>var block_td_uid_5_57dc63ed7a86c = new tdBlock();
block_td_uid_5_57dc63ed7a86c.id = "td_uid_5_57dc63ed7a86c";
block_td_uid_5_57dc63ed7a86c.atts = '{"custom_title":"TRENDING ARTICLES","limit":3,"sort":"popular","class":"td_uid_5_57dc63ed7a86c_rand"}';
block_td_uid_5_57dc63ed7a86c.td_column_number = "1";
block_td_uid_5_57dc63ed7a86c.block_type = "td_block_7";
block_td_uid_5_57dc63ed7a86c.post_count = "3";
block_td_uid_5_57dc63ed7a86c.found_posts = "25860";
block_td_uid_5_57dc63ed7a86c.header_color = "";
block_td_uid_5_57dc63ed7a86c.ajax_pagination_infinite_stop = "";
block_td_uid_5_57dc63ed7a86c.max_num_pages = "8620";
tdBlocksArray.push(block_td_uid_5_57dc63ed7a86c);
</script><div class="td_block_wrap td_block_7 td_uid_5_57dc63ed7a86c_rand td-pb-border-top"><h4 class="block-title"><span>TRENDING ARTICLES</span></h4><div id=td_uid_5_57dc63ed7a86c class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/gop-congressman-seeks-to-block-switch-to-harriet-tubman-us-currency/" rel="bookmark" title="GOP Congressman Seeks to Block Switch to Harriet Tubman $20 Bill"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/06/Rep-Steve-King-and-Harriet-Tubman-100x70.jpg" alt="" title="GOP Congressman Seeks to Block Switch to Harriet Tubman $20 Bill"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/gop-congressman-seeks-to-block-switch-to-harriet-tubman-us-currency/" rel="bookmark" title="GOP Congressman Seeks to Block Switch to Harriet Tubman $20 Bill">GOP Congressman Seeks to Block Switch to Harriet Tubman $20 Bill</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/national-news/" class="td-post-category">National News</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-06-21T23:59:16+00:00">June 21, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/fathers-day-tributes-baltimore/" rel="bookmark" title="Father&#8217;s Day Tributes &#8211; Baltimore"><img width="100" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2016/06/canstockphoto9672596-001-100x70.jpg" alt="" title="Father&#8217;s Day Tributes &#8211; Baltimore"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/fathers-day-tributes-baltimore/" rel="bookmark" title="Father&#8217;s Day Tributes &#8211; Baltimore">Father&#8217;s Day Tributes &#8211; Baltimore</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/baltimore-news/" class="td-post-category">Baltimore News</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2016-06-19T14:04:00+00:00">June 19, 2016</time></div> </div>
</div>
</div>
</div>  
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.afro.com/white-supremacist-heads-mostly-minority-school/" rel="bookmark" title="White Supremacist Heads Mostly Minority School"><img width="78" height="70" class="entry-thumb" src="http://www.afro.com/wp-content/uploads/2014/05/frank_borzellieri_opt.jpg" alt="" title="White Supremacist Heads Mostly Minority School"/></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.afro.com/white-supremacist-heads-mostly-minority-school/" rel="bookmark" title="White Supremacist Heads Mostly Minority School">White Supremacist Heads Mostly Minority School</a></h3> <div class="td-module-meta-info">
<a href="http://www.afro.com/section/afro-briefs/" class="td-post-category">Afro Briefs</a> <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2011-08-03T00:00:00+00:00">August 3, 2011</time></div> </div>
</div>
</div>
</div>  </div></div>   </div>
<div class="td-pb-span1"></div>
<div class="td-pb-span4"> <img src="http://afro.com/wp-content/uploads/2016/05/AANIC.jpg" width="50%">
<P>
<ul style="width: 70%; list-style-type: square;color: #fff;">
<li> <a href="http://www.afro.com" target="_blank">AFRO-American Newspapers</a> </li>
<li> <a href="http://theatlantavoice.com/" target="_blank">The Atlanta Voice</a></li>
<li> <a href="http://www.thechicagocitizen.com/" target="_blank">The Chicago Citizen</a></li>
<li> <a href="http://dallasweekly.com/" target="_blank">The Dallas Weekly</a></li>
<li> <a href="http://www.defendernetwork.com/" target="_blank">Defender (Houston)</a></li>
<li> <a href="http://www.indianapolisrecorder.com/" target="_blank">Indianapolis Recorder</a></li>
<li> <a href="http://www.phillytrib.com/tribune/" target="_blank">Philadelphia Tribune</a></li>
<li> <a href="http://www.stlamerican.com/" target="_blank">St. Louis American</a></li>
<li> <a href="http://www.amsterdamnews.com/" target="_blank">New York Amsterdam News</a></li>
</ul>
</div>
</div>
</div>
</div>
 
<div class="td-sub-footer-container">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span7 td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-137575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-137575"><a href="http://www.afro.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-137576" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137576"><a href="http://www.afro.com/advertise/">ADVERTISE with the AFRO</a></li>
<li id="menu-item-137577" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-137577"><a href="http://www.afro.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-137578" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-137578"><a href="/subscribe/">Subscribe</a></li>
</ul></div> </div>
<div class="td-pb-span5 td-sub-footer-copy">
&copy; Copyright 2016 - The AFRO-American Newspapers </div>
</div>
</div>
</div>
</div> 
</div> 
<script async type='text/javascript' src='http://www.afro.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?random=5.43.2'></script>
<script type="text/javascript">function ctSetCookie(c_name, value, def_value) {    document.cookie = c_name + "=" + escape(value.replace(/^def_value$/, value)) + "; path=/";}ctSetCookie("ct_checkjs", "961077041", "0");</script>
 
<div id="wppa-overlay-bg" style="text-align:center;display:none;position:fixed;top:0;left:0;z-index:100090;width:100%;height:2048px;background-color:black;" onclick="wppaOvlOnclick(event)"><div id="wppa-ovl-legenda-1" onmouseover="jQuery(this).css('visibility','visible');" onmouseout="jQuery(this).css('visibility','hidden');" style="position:absolute;left:0;top:0;background-color:black;color:#a7a7a7;visibility:visible;">
Press f for fullscreen.
</div><img id="wppa-fulls-btn" src="http://www.afro.com/wp-content/plugins/wp-photo-album-plus/images/fulls.png" style="height:32px;z-index:100091;position:fixed;top:0;right:0;" alt="Toggle fullscreen" onclick="wppaOvlFull()" ontouchstart="wppaOvlFull()" onmouseover="jQuery(this).fadeTo(600,1);" onmouseout="jQuery(this).fadeTo(600,0);"/></div><div id="wppa-overlay-ic" style="position:fixed;top:50%;left:50%;z-index:100095;opacity:1;box-shadow:none;box-sizing:content-box;"></div>
<img id="wppa-overlay-sp" alt="spinner" style="position:fixed;top:50%;margin-top:-16px;left:50%;margin-left:-16px;z-index:100100;opacity:1;visibility:hidden;box-shadow:none;" src="http://www.afro.com/wp-content/plugins/wp-photo-album-plus/images/loading.gif"/>
<script type="text/javascript">
			jQuery("#wppa-overlay-bg").css({height:window.innerHeight});
			wppaOvlModeInitial = "normal";
			wppaOvlTxtHeight = "auto";
			wppaOvlOpacity = 0.8;
			wppaOvlOnclickType = "none";
			wppaOvlTheme = "black";
			wppaOvlAnimSpeed = 300;
			wppaOvlSlideSpeed = 5000;
			wppaVer4WindowWidth = 800;
			wppaVer4WindowHeight = 600;
			wppaOvlShowCounter = true;
			
			wppaOvlFontSize = "10";
			
			wppaOvlFontWeight = "bold"
			wppaOvlLineHeight = "12"
			wppaOvlFullLegenda = "Keys: f = next mode; q,x = exit; p = previous, n = next, s = start/stop, d = dismiss this notice.";
			wppaOvlFullLegendaSingle = "Keys: f = next mode; q,x = exit; d = dismiss this notice.";
			wppaOvlVideoStart = true;
			wppaOvlAudioStart = true;
			wppaOvlShowLegenda = true;
			wppaOvlShowStartStop = true;
			wppaToggleFullScreen = "Toggle fullscreen";
			wppaIsMobile = false;
		</script>
<script type="text/javascript">
	</script>
 
 <input type="hidden" id="wppa-nonce" name="wppa-nonce" value="776a0e6cf5"/>
 
 
 
<script type='text/javascript'>
/* <![CDATA[ */
var ctf = {"ajax_url":"http:\/\/www.afro.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.afro.com/wp-content/plugins/custom-twitter-feeds/js/ctf-scripts.js?ver=1.1.1'></script>
<script type='text/javascript' src='//www.afro.com/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/wise-slams-parkdale-roosevelt-trounces-laurel\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.afro.com/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='//www.afro.com/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/wise-slams-parkdale-roosevelt-trounces-laurel\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.afro.com/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='http://www.afro.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=6.7.2'></script>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/comment-reply.min.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type='text/javascript' src='http://www.afro.com/wp-includes/js/wp-embed.min.js?ver=0734bd07978fff3de5f1935f4e07f0d3'></script>
<script type="text/javascript">
            function AI_responsive_widget() {
                jQuery('object.StefanoAI-youtube-responsive').each(function () {
                    var width = jQuery(this).parent().innerWidth();
                    var maxwidth = jQuery(this).css('max-width').replace(/px/, '');
                    var pl = parseInt(jQuery(this).parent().css('padding-left').replace(/px/, ''));
                    var pr = parseInt(jQuery(this).parent().css('padding-right').replace(/px/, ''));
                    width = width - pl - pr;
                    if (maxwidth < width) {
                        width = maxwidth;
                    }
                    jQuery(this).css('width', width + "px");
                    jQuery(this).css('height', width / (16 / 9) + "px");
                    jQuery(this).children('iframe').css('width', width + "px");
                    jQuery(this).children('iframe').css('height', width / (16 / 9) + "px");
                });
            }
            if (typeof jQuery !== 'undefined') {
                jQuery(document).ready(function () {
                    var tag = document.createElement('script');
                    tag.src = "https://www.youtube.com/iframe_api";
                    var firstScriptTag = document.getElementsByTagName('script')[0];
                    firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
                    AI_responsive_widget();
                });
                jQuery(window).resize(function () {
                    AI_responsive_widget();
                });
            }
                </script>
 
<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[144306]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.afro.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.afro.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script async type='text/javascript' src='http://www.afro.com/wp-content/plugins/cleantalk-spam-protect/inc/cleantalk_nocache.js?random=5.43.2'></script>
<script type="text/javascript">/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>